Archive for the ‘Technologies’ category

IP Netmask-Format

October 19, 2006

OK, so maybe I’m the only one with my head still stuck in the Summer of Love… but that’s OK. Juan’s “Ping from the Trenches” was a popular post, and we’re trying to hit the Top Ten list with this one as well.

Most of you were around this summer when we tried to make the ip netmask-format command work and failed utterly. The funny part is that we did get it working, we just didn’t know where to look for the expected output.

(more…)

Advertisements

Frame-Relay point to point variations

August 9, 2006

Point to Point on Physical Interfaces
!R2
interface Serial1/2
ip address 172.16.25.2 255.255.255.224
ip ospf network point-to-point
encapsulation frame-relay IETF
no keepalive
clock rate 128000
frame-relay map ip 172.16.25.2 205
frame-relay map ip 172.16.25.5 205 broadcast
no frame-relay inverse-arp
frame-relay local-dlci 502
end
!

!R5
interface Serial0/0/0
ip address 172.16.25.5 255.255.255.224
ip ospf network point-to-point
encapsulation frame-relay IETF
no keepalive
frame-relay map ip 172.16.25.2 502 broadcast
frame-relay map ip 172.16.25.5 502
no frame-relay inverse-arp
frame-relay local-dlci 205
end
!
————————————————————————————————————–
Frame-Relay Hybrid Switching on Physical Interfaces
LMI is Active

!R2
frame-relay switching
!
interface Serial1/2
ip address 172.16.25.2 255.255.255.224
ip ospf network point-to-point
encapsulation frame-relay IETF
clock rate 128000
frame-relay map ip 172.16.25.5 101 broadcast
no frame-relay inverse-arp
frame-relay intf-type dce
end
!

R5:

interface Serial0/0/0
ip address 172.16.25.5 255.255.255.224
ip ospf network point-to-point
encapsulation frame-relay IETF
no shut
frame-relay map ip 172.16.25.2 101 broadcast
no frame-relay inverse-arp
end
!
—————————————————————————————
Frame-Relay in Point-to-Point Interfaces
!R2
interface Serial1/2
no ip address
no keepalive
encapsulation frame-relay IETF
no frame-relay inverse-arp
clock rate 128000
no shut
!
interface Serial1/2.1 point-to-point
ip address 172.16.25.2 255.255.255.224
no frame-relay inverse-arp
frame-relay interface-dlci 101
end

!R5:
interface Serial0/0/0
no ip address
no keepalive
encapsulation frame-relay IETF
no frame-relay inverse-arp
clock rate 128000
no shut
!
interface Serial0/0/0.1 point-to-point
ip address 172.16.25.5 255.255.255.224
no frame-relay inverse-arp
frame-relay interface-dlci 101
end

Count on CDP

August 1, 2006

This might come in handy some day

Do you want to police route a packet, but you want to make sure the next-hop actually works before you send any policed traffic?

I just happened to come across something like that, and it’s on UniverCD

What you want is to see your next-hop on your CDP neighbors table (To ensure is “Available”)

Your route-map should look something like this

R2(config)#route-map COUNT-VON-COUNT
R2(config-route-map)#match ip address POLICED-TRAFFIC
R2(config-route-map)#set ip next-hop 192.168.10.10
R2(config-route-map)#set ip next-hop verify-availability
R2(config-route-map)#exit
R2(config)#ip local policy route-map COUNT-VON-COUNT

This should get traffic to behave accordingly

Count on it count von count Muajajajajaa
Release 12.4 / Configuration Guides / Routing Protocols Configuration Guide / Protocol-Independent Routing / Configuring IP Routing Protocol-Independent Features / Enabling NetFlow Policy Routing

OSPF area-track Tool

July 31, 2006

If you need to have an idea from wish areas your routes are comming from use this command:

R3#sh ip ospf border-routers
OSPF Process 1 internal Routing Table
Codes: i - Intra-area route, I - Inter-area route
i 172.16.105.1 [783] via 172.16.23.20, Gi0/1, ABR, Area 0,
      SPF 10
i 200.200.200.2 [2] via 172.16.23.20, Gi0/1, ABR/ASBR, Area 0,
      SPF 10
i 200.200.200.2 [1] via 172.16.23.2, Gi0/1, ABR/ASBR, Area 20,
      SPF 18
i 200.200.200.2 [781] via 172.16.234.2, Serial0/0/0.234,
      ABR/ASBR, Area 234, SPF 25
i 172.16.120.1 [1] via 172.16.23.20, Gi0/1, ABR, Area 0,
      SPF 10
i 172.16.120.1 [1] via 172.16.23.20, Gi0/1, ABR, Area 20,
      SPF 18
R3#

Good luck tracking down OSPF Routes 🙂

How to find LAN Switching Information in UniverCD

July 26, 2006

switchesOn the left-hand side of UniverCD, click ‘Catalyst Switches’ and select your switching platform. Note that the most recent documentation links sometimes do not have the hardware and software configuration documentation. Some of these links only contain the release notes, not the configuration guides.

However, you will see information below the hyperlink such as

Catalyst 3550 Multilayer Switches, Rel, 12.2(25)SEE1, May 2006
Release notes for Catalyst 3550 switches, Cisco IOS Release 12.2(25)SEE1 released during or after May 2006. NOTE: For other software and hardware documentation, see IOS Release 12.2(25)SEE.

directing you to go to 12.2(25)SEE’s documentation for the software/hardware documentation.

Try this to get acquainted with your own switches’ IOS switching documentation.

A Few Random UniverCD Links…

July 26, 2006

XML syslog:

Go to Release 12.4 -> Configuration Guides -> Network Management Configuration Guide -> System Monitoring and Logging -> XML Formatted System Logging Messages (XML Interface to syslog Messages)

Remember all those MIB groups for SNMP?

show snmp mib

questionmark.jpgUsing ‘?’ as a character:

Go to Release 12.4 -> Configuration Guides -> Terminal Services Configuration Guide -> Appendixes -> Regular Expressions

Scroll down to the additional information on the question mark!

A Long FAT Network

July 13, 2006

At first I could not belive this myself, but it is true, long FAT networks are lurking arround.

Fatty networks are the ones with high levels of choresterol 😛 Just kidding.

This is just one of those things that I had to see for myself, AND because is a LONG FAT NETWORK wasn’t really hard to spot. 😀

I know, I know it’s a lot of buzz for just ONE command. (But could be worth 6 points!)

Here it is found:

IOS Release 12.4 / Configuration Guides / Application Services / TCP / TCP Window Scaling / Setting The TCP Window Size